Shiji Payment Solutions - Processing Services - Degraded Performance in Australia

Incident Report for Astral Payments

Resolved

This incident has been resolved.
Posted May 25, 2026 - 08:15 UTC

Update

Transaction processing resumed back to normal
Posted May 23, 2026 - 07:55 UTC

Investigating

We are investigating processing problems affecting Global Blue and Windcave merchants in Australia
Posted May 23, 2026 - 06:56 UTC
This incident affected: Global Platform (Payment Processing).